<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en">
<!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
	<title>Photon Engineering Newsletter #1 | Dolske&#039;s blog</title>
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://dolske.wordpress.com/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="https://s0.wp.com/wp-content/themes/pub/twentyfourteen/js/html5.js"></script>
	<![endif]-->
	<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Dolske&#039;s blog &raquo; Feed" href="https://dolske.wordpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Dolske&#039;s blog &raquo; Comments Feed" href="https://dolske.wordpress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Dolske&#039;s blog &raquo; Photon Engineering Newsletter #1 Comments Feed" href="https://dolske.wordpress.com/2017/05/18/photon-engineering-newsletter-1/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1488818651h&ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJyNkNEOgjAMRX/IuaAE9cH4LWNUGKxsWTsJf+/AGBM0iy9Nb3tPblM5eaHdyDCyxCi8ja0ZSU5eOxSExsK8UXtNtJO/MWsGINkDe6UHsaove21d+8lxoVENyda6Wtn/vDyl1Xx3MTDAKB6H3EUBrGJohHfEG5XDtAuQ5ugVLw6ExiiwgMmWw9BXb2ppu/SFbMzrsXXtAxCJVNFEFNyloJW74bUoz6djVZSXsn8ClYCgzQ==' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfourteen-lato-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900%2C300italic%2C400italic%2C700italic&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s2.wp.com/_static/??/wp-content/mu-plugins/genericons/genericons/genericons.css,/wp-content/themes/pub/twentyfourteen/style.css?m=1492724955j' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentyfourteen-ie-css'  href='https://s0.wp.com/wp-content/themes/pub/twentyfourteen/css/ie.css?m=1405358337h&#038;ver=20131205' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='all-css-4-1' href='https://s0.wp.com/_static/??-eJx9jksOwjAMBS+EMaWAYIE4Sxu5ISiJo9hR1Ns3BYnPht0bP49lrAkMR6WoqHcKJJjKiFrbYJ64ZCWKaERQdPYENRkO28YbdBhZXZPlHV7F18lQIPliXduxxODZDOo4/gBMfnD5n5pp9GxbtM9PPrhKt3DtDufT7njp+v1jAXWkTY4=' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-5-1' href='https://s0.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-6-1' href='https://s2.wp.com/_static/??-eJx9i9EKwjAMRX/IGoVN54P4LVnp2kialCbD3xcfRGTi0z0XzoFHC1HFkzjUNTReM4kBRieVGfuH9tFsB7/1puZhYaQOVrCT5Pf+q0wjIQfWrN9nE3lJNRmUATLrjPwSbvV6HC6H83Qap/H+BMWZScE=' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFj9EKwjAMRX/IrE4m7kX8ltnFktqmtWkd+vV2oA/qUAiE3JxcbtQUgVi7MqIoW+tSMN2erbGyUr8A8GTSkLHxxC9YB87IeWZ9OJJDKIJpMFWrRqewwMUg2aNIhRa275GIr4TTX8xijoM+Q0Kh+5erLxBdMcSiErr6wAhzho+pXh38vu363aZvt93aPgArrnBz'></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dolske.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Hardware GIF' href='https://dolske.wordpress.com/2016/01/13/hardware-gif/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://dolske.wordpress.com/2017/05/18/photon-engineering-newsletter-1/" />
<link rel='shortlink' href='http://wp.me/p4ebO5-kl' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/1.0/?format=json&amp;url=https%3A%2F%2Fdolske.wordpress.com%2F2017%2F05%2F18%2Fphoton-engineering-newsletter-1%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/1.0/?format=xml&amp;url=https%3A%2F%2Fdolske.wordpress.com%2F2017%2F05%2F18%2Fphoton-engineering-newsletter-1%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Photon Engineering Newsletter #1" />
<meta property="og:url" content="https://dolske.wordpress.com/2017/05/18/photon-engineering-newsletter-1/" />
<meta property="og:description" content="Well, hello there. Let’s talk about the state of Photon, the upcoming Firefox UI refresh! You’ve likely seen Ehsan’s weekly Quantum Flow updates. They’re a great summary of the Quantum Flow work, s…" />
<meta property="article:published_time" content="2017-05-18T23:14:08+00:00" />
<meta property="article:modified_time" content="2017-05-18T23:14:08+00:00" />
<meta property="og:site_name" content="Dolske&#039;s blog" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@wordpressdotcom" />
<meta name="twitter:card" content="summary" />
<meta property="fb:app_id" content="249643311490" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<link rel="shortcut icon" type="image/x-icon" href="https://s2.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s2.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon-precomposed" href="https://s0.wp.com/i/webclip.png" />
<link rel='openid.server' href='https://dolske.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://dolske.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://dolske.wordpress.com/osd.xml" title="Dolske&#039;s blog" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="theme-color" content="#f5f5f5" />
		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
				<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="Dolske&#039;s blog" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="The odd parity bit" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://dolske.wordpress.com/feed/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="title" content="Photon Engineering Newsletter #1 | Dolske&#039;s blog on WordPress.com" />
<meta name="description" content="Well, hello there. Let’s talk about the state of Photon, the upcoming Firefox UI refresh! You’ve likely seen Ehsan’s weekly Quantum Flow updates. They’re a great summary of the Quantum Flow work, so I’m just going to copy the format for Photon too. In this update I&#039;ll briefly cover some of the notable work that&#039;s&hellip;" />
 		<script type="text/javascript">
		var _ipw_custom = {
				wordAds: '0',
				adSafe: '0',
				domain: 'dolske.wordpress.com',
				pageURL: 'https://dolske.wordpress.com/2017/05/18/photon-engineering-newsletter-1/'
			};
		</script>
 		<script type="text/javascript" src="//s.pubmine.com/head.js"></script>
		<script type="text/javascript" src="https://static.criteo.net/js/ld/publishertag.js"></script><link rel="amphtml" href="https://dolske.wordpress.com/2017/05/18/photon-engineering-newsletter-1/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>
<script type="text/javascript">
	window.google_analytics_uacct = "UA-52447-2";
</script>

<script type="text/javascript">
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-52447-2']);
	_gaq.push(['_setDomainName', 'wordpress.com']);
	_gaq.push(['_initData']);
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(ga);
	})();
</script>
</head>

<body class="post-template-default single single-post postid-1261 single-format-standard mp6 customizer-styles-applied masthead-fixed singular highlander-enabled highlander-light">
<div id="page" class="hfeed site">
	
	<header id="masthead" class="site-header" role="banner">
		<div class="header-main">
			<h1 class="site-title"><a href="https://dolske.wordpress.com/" rel="home">Dolske&#039;s blog</a></h1>

			<div class="search-toggle">
				<a href="#search-container" class="screen-reader-text" aria-expanded="false" aria-controls="search-container">Search</a>
			</div>

			<nav id="primary-navigation" class="site-navigation primary-navigation" role="navigation">
				<button class="menu-toggle">Primary Menu</button>
				<a class="screen-reader-text skip-link" href="#content">Skip to content</a>
				<div id="primary-menu" class="nav-menu"><ul>
<li class="page_item page-item-1"><a href="https://dolske.wordpress.com/about/">About</a></li>
</ul></div>
			</nav>
		</div>

		<div id="search-container" class="search-box-wrapper hide">
			<div class="search-box">
				<form role="search" method="get" class="search-form" action="https://dolske.wordpress.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>			</div>
		</div>
	</header><!-- #masthead -->

	<div id="main" class="site-main">

	<div id="primary" class="content-area">
		<div id="content" class="site-content" role="main">
			
<article id="post-1261" class="post-1261 post type-post status-publish format-standard hentry category-photonupdate category-planetmozilla">
	
	<header class="entry-header">
				<div class="entry-meta">
			<span class="cat-links"><a href="https://dolske.wordpress.com/category/photonupdate/" rel="category tag">PhotonUpdate</a>, <a href="https://dolske.wordpress.com/category/planetmozilla/" rel="category tag">PlanetMozilla</a></span>
		</div>
		<h1 class="entry-title">Photon Engineering Newsletter #1</h1>
		<div class="entry-meta">
			<span class="entry-date"><a href="https://dolske.wordpress.com/2017/05/18/photon-engineering-newsletter-1/" rel="bookmark"><time class="entry-date" datetime="2017-05-18T16:14:08+00:00">May 18, 2017</time></a></span> <span class="byline"><span class="author vcard"><a class="url fn n" href="https://dolske.wordpress.com/author/dolske/" rel="author">dolske</a></span></span>			<span class="comments-link"><a href="https://dolske.wordpress.com/2017/05/18/photon-engineering-newsletter-1/#respond">Leave a comment</a></span>
					</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

		<div class="entry-content">
		<p>Well, hello there. Let’s talk about the state of Photon, the upcoming Firefox UI refresh! You’ve likely seen <a href="https://ehsanakhgari.org/tag/quantumflow">Ehsan’s weekly Quantum Flow updates</a>. They’re a great summary of the Quantum Flow work, so I’m just going to copy the format for Photon too. In this update I&#8217;ll briefly cover some of the notable work that&#8217;s happened up through the beginning of May. I hope to do future updates on a weekly basis.</p>
<h2>Our story so far</h2>
<p>Up until recently, the Photon work hasn’t been very user-visible. It&#8217;s been lots of planning, discussion, research, prototypes, and foundational work. But now we’re at the point where we’re getting into full-speed implementation, and you’ll start to see things changing.</p>
<p>Photon is landing incrementally between now and Firefox 57. It&#8217;s enabled by default on <a href="https://www.mozilla.org/en-US/firefox/channel/desktop/#nightly">Nightly</a>, so you won’t need to enable any special settings. (Some pieces may be temporarily disabled-by-default until we get them up to a Nightly level of quality, but we&#8217;ll enable them when they&#8217;re ready for testing.) This allows us to get as much testing as possible, even in versions that ultimately won&#8217;t ship with Photon. But it does mean that Nightly users will only gradually see Photon changes arriving, instead of a big splash with everything arriving at once.</p>
<p>For Photon work that lands on Nightly-55 or Nightly-56, we&#8217;ll be disabling almost all Photon-specific changes once those versions are out of Nightly. In other words, Beta-55 and Beta-56 (and of course the final release versions, Firefox-55 and Firefox-56). That’s not where we’re actively developing or fixing bugs – so if you want to try out Photon as it&#8217;s being built, you should stick with Nightly. Users on Beta or Release won&#8217;t see Photon until 57 starts to ship on those channels later this year.</p>
<p>The Photon work is split into 6 main areas (which is also how the teams implementing it are organized). These are, briefly:</p>
<p>1. Menus and structure &#8211; Replaces the existing application menu (&#8220;Hamburger button&#8221;) with a simplified linear menu, adds a &#8220;page action&#8221; menu, changes the bookmarks split-button to be a more general-purpose &#8220;library menu&#8221;, updates sidebars, and more.</p>
<p>2. Animation &#8211; Adds animation to toolbar button actions, and improves animations/transitions of other UI elements (like tabs and menus).</p>
<p>3. Preferences &#8211; Reorganizes the Firefox preferences UI to improve organization and adds the ability to search.</p>
<p>4. Visual redesign &#8211; This is a collection of other visual changes for Photon. Updating icons, changing toolbar buttons, adapting UI size when using touchscreens, and many other general UI refinements.</p>
<p>5. Onboarding &#8211; An important part of the Photon experience is helping new users understand what&#8217;s great about Firefox, and showing existing users what&#8217;s new and different in 57.</p>
<p>6. Performance &#8211; Performance is a key piece throughout Photon, but the Performance team is helping us to identify what areas of Firefox have issues. Some of this work overlaps with Quantum Flow, other work is improve specific areas of Firefox UI jank.</p>
<h2>Recent Changes</h2>
<p>These updates are going to focus more on the work that&#8217;s landing and less on the process that got it there. To start getting caught up, here&#8217;s a summary of what&#8217;s happened so far in each of the project areas though early May&#8230;</p>
<p>Menus/structure: Work is underway to implement the new menus. It&#8217;s currently behind a pref until we have enough implemented to turn them on without making Nightly awkward to use. In <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1355331">bug 1355331</a> we briefly moved the sidebar to the right side of the window instead of the left. But we&#8217;ve since decided that we&#8217;re only going to provide a preference to allow putting it on the right, and it will remain on the left by default.</p>
<p>Animation: In <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1352069">bug 1352069</a> we consolidated some existing preferences into a single new <span id="summary_alias_container"><span id="short_desc_nonedit_display">toolkit.cosmeticAnimations.enabled</span></span> preference, to make it easy to disable non-essential animations for performance or accessibility reasons. Bugs <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1345315">1345315</a> and <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1356655">1356655</a> reduced jank in the tab opening/closing animations. The UX team is finalizing the new animations that will be used in Photon, and the engineering team has build prototypes for how to implement them in a way that performs well.</p>
<p>Preferences: Earlier in the year, we worked with a group of students at Michigan State University to reorganize Firefox&#8217;s preferences and add a search function (<a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1324168">bug 1324168</a>). We&#8217;re now completing some final work, preparing for a second revision, and adding some new UI for <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1354473">performance settings</a>. While this is now considered part of Photon, it was originally scheduled to land in Firefox 55 or 56, and so will ship before the rest of Photon.</p>
<p>Visual redesign:  <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1347543">Bug 1347543</a> landed a major change to the icons in Firefox&#8217;s UI. Previously the icons were simple PNG bitmaps, with different versions for OS variations and display scaling factors. Now they&#8217;re a vector format (SVG), allowing a single source file to be be rendered within Firefox at different sizes or with different <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1058040">colors</a>. You won&#8217;t notice this change, because we&#8217;re currently using SVG versions of the current pre-Photon icons. We&#8217;ll switch to the final <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1355455">Photon icons</a> later, for Firefox 57. Another big foundational piece of work landed in <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1352364">bug 1352364</a>, which refactored our toolbar button CSS so that we can easily update it for Photon.</p>
<p>Onboarding: The onboarding work got started later than other parts of Photon. So while some prototyping has started, most of the work up to May was spent finalizing the scope and design of project.</p>
<p>Performance: As <a href="https://ehsanakhgari.org/blog/2017-05-05/quantum-flow-engineering-newsletter-8">noted</a> in Ehsan&#8217;s Quantum updates, the Photon performance work has already resulted in a significant improvement to Firefox startup time. Other notable fixes have made <a href="https://mikeconley.ca/blog/2017/05/01/making-tabs-close-faster-in-multi-process-firefox/">closing tabs faster</a>, and work to <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=977177">improve how favicons</a> <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1356220">are stored</a> improved performance on our Tp5 page-load benchmark by 30%! <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1353563">Other</a> <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1312999">fixes</a> have reduced awesomebar jank. While a number of performance bugs have been fixed (of which these are just a subset), most of the focus so far has been on profiling Firefox to identify lots of other things to fix. And it&#8217;s also worth noting the great <a href="https://developer.mozilla.org/en-US/Firefox/Performance_best_practices_for_Firefox_fe_engineers">Performance Best Practices</a> guide Mike Conley helped put together, as well as his <a href="https://mikeconley.github.io/ohnoreflow/">Oh No! Reflow! add-on</a>, which is a useful tool for finding synchronous reflows in Firefox UI (which cause jank).</p>
<p>That&#8217;s it for now! The next couple of these Photon updates will catch up with what&#8217;s currently underway.</p>
		<div class="wpcnt">
			<div class="wpa wpmrec">
				<span class="wpa-about">Advertisements</span>
				<div class="u">
								<script type='text/javascript'>
				(function(g){if("undefined"!=typeof g.__ATA){g.__ATA.initAd({sectionId:26942, width:300, height:250});}})(window);
			</script>
				</div>
				        <div id="crt-1513955949" style="width:300px;height:250px;"></div>
        <script type="text/javascript">
        var o = document.getElementById('crt-1513955949');
        if ("undefined"!=typeof Criteo) {
            var p = o.parentNode;
            p.style.setProperty('display', 'inline-block', 'important');
            o.style.setProperty('display', 'block', 'important');
            Criteo.DisplayAcceptableAdIfAdblocked({zoneid:388248,containerid:"crt-1513955949",collapseContainerIfNotAdblocked:true,"callifnotadblocked": function () {var o = document.getElementById('crt-1513955949'); o.style.setProperty('display','none','important');o.style.setProperty('visbility','hidden','important'); }
        });
        } else {
            o.style.setProperty('display', 'none', 'important');
            o.style.setProperty('visibility', 'hidden', 'important');
        }
        </script>
			</div>
		</div><div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-1261" class="share-twitter sd-button share-icon" href="https://dolske.wordpress.com/2017/05/18/photon-engineering-newsletter-1/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-1261" class="share-facebook sd-button share-icon" href="https://dolske.wordpress.com/2017/05/18/photon-engineering-newsletter-1/?share=facebook" target="_blank" title="Share on Facebook"><span>Facebook</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-1261" class="share-google-plus-1 sd-button share-icon" href="https://dolske.wordpress.com/2017/05/18/photon-engineering-newsletter-1/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="https://dolske.wordpress.com/2017/05/18/photon-engineering-newsletter-1/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-1261" class="share-pinterest sd-button share-icon" href="https://dolske.wordpress.com/2017/05/18/photon-engineering-newsletter-1/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-62487325-1261-591e32f6e4471' data-src='//widgets.wp.com/likes/#blog_id=62487325&amp;post_id=1261&amp;origin=dolske.wordpress.com&amp;obj_id=62487325-1261-591e32f6e4471' data-name='like-post-frame-62487325-1261-591e32f6e4471'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>	</div><!-- .entry-content -->
	
	</article><!-- #post-## -->
	<nav class="navigation post-navigation" role="navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<div class="nav-links">
			<a href="https://dolske.wordpress.com/2016/01/13/hardware-gif/" rel="prev"><span class="meta-nav">Previous Post</span>Hardware GIF</a>		</div><!-- .nav-links -->
	</nav><!-- .navigation -->
	
<div id="comments" class="comments-area">

	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/05/18/photon-engineering-newsletter-1/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://dolske.wordpress.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="282514b40b" /><input type="hidden" name="_wp_http_referer" value="/2017/05/18/photon-engineering-newsletter-1/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">

	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" title="Guest">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" title="WordPress.com">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" title="Twitter">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" title="Facebook">
					<span></span>
				</a>
			</li>
			<li>
			<iframe id="googleplus-sign-in" name="googleplus-sign-in" src="https://public-api.wordpress.com/connect/?googleplus-sign-in=https%3A%2F%2Fdolske.wordpress.com" width="24" height="24" scrolling="no" allowtransparency="true" seamless="seamless" frameborder="0"></iframe>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=retro&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=retro&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
				<p class="comment-form-posting-as pa-wordpress"><strong></strong> You are commenting using your WordPress.com account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=retro&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
				<p class="comment-form-posting-as pa-twitter"><strong></strong> You are commenting using your Twitter account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=retro&amp;forcedefault=y&amp;r=G" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
				<p class="comment-form-posting-as pa-facebook"><strong></strong> You are commenting using your Facebook account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=retro&amp;forcedefault=y&amp;r=G" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
				<p class="comment-form-posting-as pa-googleplus"><strong></strong> You are commenting using your Google+ account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1261' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="9a4a9f3290" /></p>
<input type="hidden" name="genseq" value="1495151350" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="183"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>
</div><!-- #comments -->
		</div><!-- #content -->
	</div><!-- #primary -->

<div id="content-sidebar" class="content-sidebar widget-area" role="complementary">
	<aside id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://dolske.wordpress.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside>		<aside id="recent-posts-2" class="widget widget_recent_entries">		<h1 class="widget-title">Recent Posts</h1>		<ul>
					<li>
				<a href="https://dolske.wordpress.com/2017/05/18/photon-engineering-newsletter-1/">Photon Engineering Newsletter #1</a>
						</li>
					<li>
				<a href="https://dolske.wordpress.com/2016/01/13/hardware-gif/">Hardware GIF</a>
						</li>
					<li>
				<a href="https://dolske.wordpress.com/2015/11/20/foxkeh-dance-is-back/">Foxkeh Dance is back!</a>
						</li>
					<li>
				<a href="https://dolske.wordpress.com/2014/10/31/that-time-of-year/">That time of year</a>
						</li>
					<li>
				<a href="https://dolske.wordpress.com/2014/10/26/stellar-paparazzi/">Stellar Paparazzi</a>
						</li>
				</ul>
		</aside>		<aside id="recent-comments-2" class="widget widget_recent_comments"><h1 class="widget-title">Recent Comments</h1>				<table class="recentcommentsavatar" cellspacing="0" cellpadding="0" border="0">
					<tr><td title="RyanVM" class="recentcommentsavatartop" style="height:48px; width:48px;"><a href="http://gravatar.com/ryanvm" rel="nofollow"><img alt='' src='https://1.gravatar.com/avatar/a10f7f199c75a9a5a1eb347730524a7a?s=48&#038;d=retro&#038;r=G' class='avatar avatar-48' height='48' width='48' /></a></td><td class="recentcommentstexttop" style=""><a href="http://gravatar.com/ryanvm" rel="nofollow">RyanVM</a> on <a href="https://dolske.wordpress.com/2016/01/13/hardware-gif/comment-page-1/#comment-1201">Hardware GIF</a></td></tr><tr><td title="kensaunders" class="recentcommentsavatarend" style="height:48px; width:48px;"><a href="http://www.accessfirefox.org" rel="nofollow"><img alt='' src='https://0.gravatar.com/avatar/34b2b2764cd9b375de7c7e8292daed39?s=48&#038;d=retro&#038;r=G' class='avatar avatar-48' height='48' width='48' /></a></td><td class="recentcommentstextend" style=""><a href="http://www.accessfirefox.org" rel="nofollow">kensaunders</a> on <a href="https://dolske.wordpress.com/2016/01/13/hardware-gif/comment-page-1/#comment-1200">Hardware GIF</a></td></tr><tr><td title="A Comment" class="recentcommentsavatarend" style="height:48px; width:48px;"><img alt='' src='https://0.gravatar.com/avatar/9635a29f21433f89f91653517b32358c?s=48&#038;d=retro&#038;r=G' class='avatar avatar-48' height='48' width='48' /></td><td class="recentcommentstextend" style="">A Comment on <a href="https://dolske.wordpress.com/2014/10/16/sans-flash/comment-page-1/#comment-1194">Sans Flash</a></td></tr><tr><td title="A Comment" class="recentcommentsavatarend" style="height:48px; width:48px;"><img alt='' src='https://0.gravatar.com/avatar/9635a29f21433f89f91653517b32358c?s=48&#038;d=retro&#038;r=G' class='avatar avatar-48' height='48' width='48' /></td><td class="recentcommentstextend" style="">A Comment on <a href="https://dolske.wordpress.com/2014/10/16/sans-flash/comment-page-1/#comment-1193">Sans Flash</a></td></tr><tr><td title="tedmielczarek" class="recentcommentsavatarend" style="height:48px; width:48px;"><img alt='' src='https://0.gravatar.com/avatar/30fa9f928422bef2f98dd5f564def686?s=48&#038;d=retro&#038;r=G' class='avatar avatar-48' height='48' width='48' /></td><td class="recentcommentstextend" style="">tedmielczarek on <a href="https://dolske.wordpress.com/2014/10/16/sans-flash/comment-page-1/#comment-1192">Sans Flash</a></td></tr>				</table>
				</aside><aside id="archives-2" class="widget widget_archive"><h1 class="widget-title">Archives</h1>		<ul>
			<li><a href='https://dolske.wordpress.com/2017/05/'>May 2017</a></li>
	<li><a href='https://dolske.wordpress.com/2016/01/'>January 2016</a></li>
	<li><a href='https://dolske.wordpress.com/2015/11/'>November 2015</a></li>
	<li><a href='https://dolske.wordpress.com/2014/10/'>October 2014</a></li>
	<li><a href='https://dolske.wordpress.com/2014/05/'>May 2014</a></li>
	<li><a href='https://dolske.wordpress.com/2014/04/'>April 2014</a></li>
	<li><a href='https://dolske.wordpress.com/2014/03/'>March 2014</a></li>
	<li><a href='https://dolske.wordpress.com/2013/10/'>October 2013</a></li>
	<li><a href='https://dolske.wordpress.com/2013/09/'>September 2013</a></li>
	<li><a href='https://dolske.wordpress.com/2013/08/'>August 2013</a></li>
	<li><a href='https://dolske.wordpress.com/2013/03/'>March 2013</a></li>
	<li><a href='https://dolske.wordpress.com/2013/02/'>February 2013</a></li>
	<li><a href='https://dolske.wordpress.com/2012/11/'>November 2012</a></li>
	<li><a href='https://dolske.wordpress.com/2012/10/'>October 2012</a></li>
	<li><a href='https://dolske.wordpress.com/2012/07/'>July 2012</a></li>
	<li><a href='https://dolske.wordpress.com/2012/06/'>June 2012</a></li>
	<li><a href='https://dolske.wordpress.com/2012/04/'>April 2012</a></li>
	<li><a href='https://dolske.wordpress.com/2011/12/'>December 2011</a></li>
	<li><a href='https://dolske.wordpress.com/2011/09/'>September 2011</a></li>
	<li><a href='https://dolske.wordpress.com/2011/08/'>August 2011</a></li>
	<li><a href='https://dolske.wordpress.com/2011/06/'>June 2011</a></li>
	<li><a href='https://dolske.wordpress.com/2011/04/'>April 2011</a></li>
	<li><a href='https://dolske.wordpress.com/2011/03/'>March 2011</a></li>
	<li><a href='https://dolske.wordpress.com/2010/12/'>December 2010</a></li>
	<li><a href='https://dolske.wordpress.com/2010/08/'>August 2010</a></li>
	<li><a href='https://dolske.wordpress.com/2010/05/'>May 2010</a></li>
	<li><a href='https://dolske.wordpress.com/2010/04/'>April 2010</a></li>
	<li><a href='https://dolske.wordpress.com/2010/03/'>March 2010</a></li>
	<li><a href='https://dolske.wordpress.com/2010/02/'>February 2010</a></li>
	<li><a href='https://dolske.wordpress.com/2010/01/'>January 2010</a></li>
	<li><a href='https://dolske.wordpress.com/2009/12/'>December 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2009/10/'>October 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2009/09/'>September 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2009/08/'>August 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2009/06/'>June 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2009/05/'>May 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2009/03/'>March 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2009/02/'>February 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2009/01/'>January 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2008/10/'>October 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/09/'>September 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/08/'>August 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/07/'>July 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/06/'>June 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/05/'>May 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/04/'>April 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/03/'>March 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/02/'>February 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/01/'>January 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2007/11/'>November 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/10/'>October 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/09/'>September 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/08/'>August 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/07/'>July 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/06/'>June 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/05/'>May 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/04/'>April 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/03/'>March 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/02/'>February 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/01/'>January 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2006/12/'>December 2006</a></li>
	<li><a href='https://dolske.wordpress.com/2006/11/'>November 2006</a></li>
		</ul>
		</aside><aside id="categories-2" class="widget widget_categories"><h1 class="widget-title">Categories</h1>		<ul>
	<li class="cat-item cat-item-45"><a href="https://dolske.wordpress.com/category/firefox/" >Firefox</a>
</li>
	<li class="cat-item cat-item-1132563"><a href="https://dolske.wordpress.com/category/fuzzy-friends/" >Fuzzy Friends</a>
</li>
	<li class="cat-item cat-item-3285906"><a href="https://dolske.wordpress.com/category/mozilla-labs/" >Mozilla Labs</a>
</li>
	<li class="cat-item cat-item-577408141"><a href="https://dolske.wordpress.com/category/photonupdate/" >PhotonUpdate</a>
</li>
	<li class="cat-item cat-item-207156360"><a href="https://dolske.wordpress.com/category/planetfirefox/" >PlanetFirefox</a>
</li>
	<li class="cat-item cat-item-11777878"><a href="https://dolske.wordpress.com/category/planetmozilla/" >PlanetMozilla</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://dolske.wordpress.com/category/technology/" >Technology</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://dolske.wordpress.com/category/uncategorized/" >Uncategorized</a>
</li>
		</ul>
</aside><aside id="meta-2" class="widget widget_meta"><h1 class="widget-title">Meta</h1>			<ul>
			<li><a href="https://wordpress.com/start?ref=wplogin">Register</a></li>			<li><a href="https://dolske.wordpress.com/wp-login.php">Log in</a></li>
			<li><a href="https://dolske.wordpress.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://dolske.wordpress.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.com/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.com</a></li>			</ul>
			</aside></div><!-- #content-sidebar -->
<div id="secondary">
			<h2 class="site-description">The odd parity bit</h2>
	
	
		<div id="primary-sidebar" class="primary-sidebar widget-area" role="complementary">
		<aside id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://dolske.wordpress.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside>		<aside id="recent-posts-2" class="widget widget_recent_entries">		<h1 class="widget-title">Recent Posts</h1>		<ul>
					<li>
				<a href="https://dolske.wordpress.com/2017/05/18/photon-engineering-newsletter-1/">Photon Engineering Newsletter #1</a>
						</li>
					<li>
				<a href="https://dolske.wordpress.com/2016/01/13/hardware-gif/">Hardware GIF</a>
						</li>
					<li>
				<a href="https://dolske.wordpress.com/2015/11/20/foxkeh-dance-is-back/">Foxkeh Dance is back!</a>
						</li>
					<li>
				<a href="https://dolske.wordpress.com/2014/10/31/that-time-of-year/">That time of year</a>
						</li>
					<li>
				<a href="https://dolske.wordpress.com/2014/10/26/stellar-paparazzi/">Stellar Paparazzi</a>
						</li>
				</ul>
		</aside>		<aside id="recent-comments-2" class="widget widget_recent_comments"><h1 class="widget-title">Recent Comments</h1>				<table class="recentcommentsavatar" cellspacing="0" cellpadding="0" border="0">
					<tr><td title="RyanVM" class="recentcommentsavatartop" style="height:48px; width:48px;"><a href="http://gravatar.com/ryanvm" rel="nofollow"><img alt='' src='https://1.gravatar.com/avatar/a10f7f199c75a9a5a1eb347730524a7a?s=48&#038;d=retro&#038;r=G' class='avatar avatar-48' height='48' width='48' /></a></td><td class="recentcommentstexttop" style=""><a href="http://gravatar.com/ryanvm" rel="nofollow">RyanVM</a> on <a href="https://dolske.wordpress.com/2016/01/13/hardware-gif/comment-page-1/#comment-1201">Hardware GIF</a></td></tr><tr><td title="kensaunders" class="recentcommentsavatarend" style="height:48px; width:48px;"><a href="http://www.accessfirefox.org" rel="nofollow"><img alt='' src='https://0.gravatar.com/avatar/34b2b2764cd9b375de7c7e8292daed39?s=48&#038;d=retro&#038;r=G' class='avatar avatar-48' height='48' width='48' /></a></td><td class="recentcommentstextend" style=""><a href="http://www.accessfirefox.org" rel="nofollow">kensaunders</a> on <a href="https://dolske.wordpress.com/2016/01/13/hardware-gif/comment-page-1/#comment-1200">Hardware GIF</a></td></tr><tr><td title="A Comment" class="recentcommentsavatarend" style="height:48px; width:48px;"><img alt='' src='https://0.gravatar.com/avatar/9635a29f21433f89f91653517b32358c?s=48&#038;d=retro&#038;r=G' class='avatar avatar-48' height='48' width='48' /></td><td class="recentcommentstextend" style="">A Comment on <a href="https://dolske.wordpress.com/2014/10/16/sans-flash/comment-page-1/#comment-1194">Sans Flash</a></td></tr><tr><td title="A Comment" class="recentcommentsavatarend" style="height:48px; width:48px;"><img alt='' src='https://0.gravatar.com/avatar/9635a29f21433f89f91653517b32358c?s=48&#038;d=retro&#038;r=G' class='avatar avatar-48' height='48' width='48' /></td><td class="recentcommentstextend" style="">A Comment on <a href="https://dolske.wordpress.com/2014/10/16/sans-flash/comment-page-1/#comment-1193">Sans Flash</a></td></tr><tr><td title="tedmielczarek" class="recentcommentsavatarend" style="height:48px; width:48px;"><img alt='' src='https://0.gravatar.com/avatar/30fa9f928422bef2f98dd5f564def686?s=48&#038;d=retro&#038;r=G' class='avatar avatar-48' height='48' width='48' /></td><td class="recentcommentstextend" style="">tedmielczarek on <a href="https://dolske.wordpress.com/2014/10/16/sans-flash/comment-page-1/#comment-1192">Sans Flash</a></td></tr>				</table>
				</aside><aside id="archives-2" class="widget widget_archive"><h1 class="widget-title">Archives</h1>		<ul>
			<li><a href='https://dolske.wordpress.com/2017/05/'>May 2017</a></li>
	<li><a href='https://dolske.wordpress.com/2016/01/'>January 2016</a></li>
	<li><a href='https://dolske.wordpress.com/2015/11/'>November 2015</a></li>
	<li><a href='https://dolske.wordpress.com/2014/10/'>October 2014</a></li>
	<li><a href='https://dolske.wordpress.com/2014/05/'>May 2014</a></li>
	<li><a href='https://dolske.wordpress.com/2014/04/'>April 2014</a></li>
	<li><a href='https://dolske.wordpress.com/2014/03/'>March 2014</a></li>
	<li><a href='https://dolske.wordpress.com/2013/10/'>October 2013</a></li>
	<li><a href='https://dolske.wordpress.com/2013/09/'>September 2013</a></li>
	<li><a href='https://dolske.wordpress.com/2013/08/'>August 2013</a></li>
	<li><a href='https://dolske.wordpress.com/2013/03/'>March 2013</a></li>
	<li><a href='https://dolske.wordpress.com/2013/02/'>February 2013</a></li>
	<li><a href='https://dolske.wordpress.com/2012/11/'>November 2012</a></li>
	<li><a href='https://dolske.wordpress.com/2012/10/'>October 2012</a></li>
	<li><a href='https://dolske.wordpress.com/2012/07/'>July 2012</a></li>
	<li><a href='https://dolske.wordpress.com/2012/06/'>June 2012</a></li>
	<li><a href='https://dolske.wordpress.com/2012/04/'>April 2012</a></li>
	<li><a href='https://dolske.wordpress.com/2011/12/'>December 2011</a></li>
	<li><a href='https://dolske.wordpress.com/2011/09/'>September 2011</a></li>
	<li><a href='https://dolske.wordpress.com/2011/08/'>August 2011</a></li>
	<li><a href='https://dolske.wordpress.com/2011/06/'>June 2011</a></li>
	<li><a href='https://dolske.wordpress.com/2011/04/'>April 2011</a></li>
	<li><a href='https://dolske.wordpress.com/2011/03/'>March 2011</a></li>
	<li><a href='https://dolske.wordpress.com/2010/12/'>December 2010</a></li>
	<li><a href='https://dolske.wordpress.com/2010/08/'>August 2010</a></li>
	<li><a href='https://dolske.wordpress.com/2010/05/'>May 2010</a></li>
	<li><a href='https://dolske.wordpress.com/2010/04/'>April 2010</a></li>
	<li><a href='https://dolske.wordpress.com/2010/03/'>March 2010</a></li>
	<li><a href='https://dolske.wordpress.com/2010/02/'>February 2010</a></li>
	<li><a href='https://dolske.wordpress.com/2010/01/'>January 2010</a></li>
	<li><a href='https://dolske.wordpress.com/2009/12/'>December 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2009/10/'>October 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2009/09/'>September 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2009/08/'>August 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2009/06/'>June 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2009/05/'>May 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2009/03/'>March 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2009/02/'>February 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2009/01/'>January 2009</a></li>
	<li><a href='https://dolske.wordpress.com/2008/10/'>October 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/09/'>September 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/08/'>August 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/07/'>July 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/06/'>June 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/05/'>May 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/04/'>April 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/03/'>March 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/02/'>February 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2008/01/'>January 2008</a></li>
	<li><a href='https://dolske.wordpress.com/2007/11/'>November 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/10/'>October 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/09/'>September 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/08/'>August 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/07/'>July 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/06/'>June 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/05/'>May 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/04/'>April 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/03/'>March 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/02/'>February 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2007/01/'>January 2007</a></li>
	<li><a href='https://dolske.wordpress.com/2006/12/'>December 2006</a></li>
	<li><a href='https://dolske.wordpress.com/2006/11/'>November 2006</a></li>
		</ul>
		</aside><aside id="categories-2" class="widget widget_categories"><h1 class="widget-title">Categories</h1>		<ul>
	<li class="cat-item cat-item-45"><a href="https://dolske.wordpress.com/category/firefox/" >Firefox</a>
</li>
	<li class="cat-item cat-item-1132563"><a href="https://dolske.wordpress.com/category/fuzzy-friends/" >Fuzzy Friends</a>
</li>
	<li class="cat-item cat-item-3285906"><a href="https://dolske.wordpress.com/category/mozilla-labs/" >Mozilla Labs</a>
</li>
	<li class="cat-item cat-item-577408141"><a href="https://dolske.wordpress.com/category/photonupdate/" >PhotonUpdate</a>
</li>
	<li class="cat-item cat-item-207156360"><a href="https://dolske.wordpress.com/category/planetfirefox/" >PlanetFirefox</a>
</li>
	<li class="cat-item cat-item-11777878"><a href="https://dolske.wordpress.com/category/planetmozilla/" >PlanetMozilla</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://dolske.wordpress.com/category/technology/" >Technology</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://dolske.wordpress.com/category/uncategorized/" >Uncategorized</a>
</li>
		</ul>
</aside><aside id="meta-2" class="widget widget_meta"><h1 class="widget-title">Meta</h1>			<ul>
			<li><a href="https://wordpress.com/start?ref=wplogin">Register</a></li>			<li><a href="https://dolske.wordpress.com/wp-login.php">Log in</a></li>
			<li><a href="https://dolske.wordpress.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://dolske.wordpress.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.com/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.com</a></li>			</ul>
			</aside>	</div><!-- #primary-sidebar -->
	</div><!-- #secondary -->

		</div><!-- #main -->

		<footer id="colophon" class="site-footer" role="contentinfo">

			
			<div class="site-info">
								<a href="https://wordpress.com/?ref=footer_blog">Blog at WordPress.com.</a>
			</div><!-- .site-info -->
		</footer><!-- #colophon -->
	</div><!-- #page -->

	<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201720y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	<div class="grofile-hash-map-a10f7f199c75a9a5a1eb347730524a7a">
	</div>
	<div class="grofile-hash-map-34b2b2764cd9b375de7c7e8292daed39">
	</div>
	<div class="grofile-hash-map-9635a29f21433f89f91653517b32358c">
	</div>
	<div class="grofile-hash-map-30fa9f928422bef2f98dd5f564def686">
	</div>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/dolske.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/dolske.wordpress.com\/wp-login.php?action=logout&_wpnonce=bb8ce03fc3","homeURL":"https:\/\/dolske.wordpress.com\/","postID":"1261","gravDefault":"retro","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"0","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/dolske.wordpress.com\/2017\/05\/18\/photon-engineering-newsletter-1\/":1261};
	</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-google-plus-1' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
		});
		</script>
							<script type="text/javascript">
				jQuery(document).on('ready', function(){
					jQuery('body').on('click', 'a.share-pinterest', function(e){
						e.preventDefault();
						// Load Pinterest Bookmarklet code
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = window.location.protocol + "//assets.pinterest.com/js/pinmarklet.js?r=" + ( Math.random() * 99999999 );
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
						// Trigger Stats
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = this + ( this.toString().indexOf( '?' ) ? '&' : '?' ) + 'js_only=1';
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
					});
				});
			</script>
		<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/akismet-3.0/_inc/form.js?m=1404442431h'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"62487325","siteName":"Dolske's blog","siteURL":"http:\/\/dolske.wordpress.com","icon":"<img alt='' src='https:\/\/s1.wp.com\/i\/logo\/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/twentyfourteen","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/dolske.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fdolske.wordpress.com%2F2017%2F05%2F18%2Fphoton-engineering-newsletter-1%2F","themeURL":"https:\/\/wordpress.com\/theme\/twentyfourteen\/","xhrURL":"https:\/\/dolske.wordpress.com\/wp-admin\/admin-ajax.php","nonce":"f8b4720e07","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"0fcc2898d8\" \/>","referer":"https:\/\/dolske.wordpress.com\/2017\/05\/18\/photon-engineering-newsletter-1\/","canFollow":"1","statusMessage":"","customizeLink":"https:\/\/dolske.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fdolske.wordpress.com%2F2017%2F05%2F18%2Fphoton-engineering-newsletter-1%2F","postID":"1261","shortlink":"http:\/\/wp.me\/p4ebO5-kl","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/dolske.wordpress.com\/1261","statsLink":"https:\/\/wordpress.com\/stats\/post\/1261\/dolske.wordpress.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Twenty Fourteen","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in the Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/dolske.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fdolske.wordpress.com%2F2017%2F05%2F18%2Fphoton-engineering-newsletter-1%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJx9jtsOgjAMhl/IWTBG44XxWcYoUty62W0gb+8wkRgvuGrzH74WpqCM54ScYIjQ4kgGw2s/xB38WC6rYPOdOIKlB0Z4ZszYa24tyjdMbGxui1lAxjtXikow2HnviP+JqUdXoiE3kKYizJ3PkhB5aXeZTSLPceMP3RaqarSA0zGhlE35EUVoeWHVtgifGwth3TbSwcekOqtJIPZaiO/fWUo3d62Pl0NVnerDeXgDeRl/4Q=='></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>	<script type="text/javascript">
	var skimlinks_pub_id = "725X584219"
	var skimlinks_sitename = "dolske.wordpress.com";
	</script>
	<script type="text/javascript" defer src="https://s.skimresources.com/js/725X1342.skimlinks.js"></script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20170206#ver=20170206' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
		<script>
			var _comscore = _comscore || [];
			_comscore.push({
				c1: "2",
				c2: "7518284"
			});
			(function() {
				var s = document.createElement("script"),
					el = document.getElementsByTagName("script")[0];
				s.defer = true;
				s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
				el.parentNode.insertBefore(s, el);
			})();
		</script>
		<noscript>
			<p class="robots-nocontent"><img src="https://sb.scorecardresearch.com/p?c1=2&c2=7518284&c3=&c4=&c5=&c6=&c15=&cv=2.0&cj=1" alt="" style="display:none;" width="1" height="1" /></p>
		</noscript><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'62487325','blog_tz':'-7','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'62487325','v':'wpcom','tz':'-7','user_id':'0','post':'1261','subd':'dolske'}]);
_stq.push(['extra', {'crypt':'UE5XaGUuOTlwaD85flAmcm1mcmZsaDhkV11YdTdvUG14Q2VDQTR4LlUsLi82dU1mai9BMkM9QjRQOXBLb118UjRaLGxaPzQ5LTQlU1BOLFJ2OCZheEU/ejJidV1jT05uMzhpK3JHM0p0aWJNK1lmSGJscyY1WVZEVjZCZ3xvVmYrK1NsfjMldXkyZjlSUDdpakN6OUNMWTVKMnkrZ0hrQ2lHcEFqT0R5MmIsbVg3TW8vSUpIVUVML0MmfHx0WS1yNWIyRklpJktrMUZ8KzEzOFdkPVJrXU9UbGJ4fEF1Z0pCPUJSLSZFWitZQUFqYmZYeXp6NHJNNS5ScEsmZTFMUks5b2F3PXNodkJyNjhGfmR3Y1tGN3Q0cG9IRElQZ0M='}]);
_stq.push([ 'clickTrackerInit', '62487325', '1261' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>
<!--
	generated 8 seconds ago
	generated in 0.122 seconds
	served from batcache in 0.001 seconds
	expires in 292 seconds
-->
